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Crestron Fusion® Add-In for Outlook® 
Installation Guide: Meeting 
Scheduling Software 

Introduction 
The Crestron Fusion® Add-In for Outlook® adds the Fusion RV® Room Booking Wizard 
functionality to Microsoft® Outlook. This feature helps the user find available rooms and 
resources and sets actions and presets for meetings or appointments. This document is 
provided as an aid for installing the Outlook Web Service (OLWS) and Crestron Fusion  
Add-In for Outlook (OLAI). 

For more information on how to use the Crestron Fusion Add-In for Outlook, refer to the 
Crestron Fusion Add-In for Outlook User Guide (Doc. 7771.) 

Rights 
The rights to install the OLAI software depend on the company’s choice of operating 
systems and security policies. 

Version Compatibility 
Crestron Fusion supports Microsoft Outlook versions 2007, 2010, 2013, and Office 365™. 
Each new version of the OLWS and the OLAI support all previous versions of the software. 
No compromise in existing functionality occurs. However, some new features might not be 
available if versions are mixed. To avoid any software issues, Crestron® recommends using 
the current version of the Crestron Fusion software. For additional information, contact the 
Crestron Fusion Support Group at 1-888-273-7876. 

Configuration Settings 
The configuration settings are held in a text file named OLAI.config. The configuration file 
contains the following settings: 

ServerPath: The ServerPath is the URL to the OLWS without the file name. 

Language: The language to be used in the OLAI User Interface (UI). 

BookSingle: If the Book Single button is visible, then the value is true or false. BookSingle 
allows the user to quickly select a room for a meeting. The user can review the assets and 
custom fields for a particular room and bypass the room availability search. Microsoft 
Exchange declines the request if the room is busy. 



 

2 • Crestron Fusion Add-In for Outlook: Meeting Scheduling Software  Installation Guide – DOC. 7726B 

Installation 
The OLAI can be installed as a single instance on a PC or deployed to multiple PCs over a 
network using group policies. The OLWS needs to be installed before the OLAI on the 
Fusion RV server or in a place where the room, schedule, and asset services have access to 
it. 

The installation is a two-part process as follows: 

1. Install the OLWS server-side software. 

Only one version of the OLWS is available. The OLWS installer is not specific to the 
32- or 64-bit versions of Outlook. The OLWS runtime automatically switches 
between 32- and 64-bit. 

2. Install the Crestron Fusion Add-In for Outlook client-side software. 

Depending on your version of Outlook, use the 32- or 64-bit installer and then 
select an installation option (UI assisted or command line).  

•  The UI assisted installation is a desktop installation that uses the Previous 
and Next buttons to move through the installation. This method is not 
suited for production rollouts. Note that BookSingle is not available. 

•  The command line installation is typically used for automated distribution 
installations in large facilities. It includes switches to hide the User Interface 
(UI), server URL, and BookSingle activation. 

If you encounter any issues when installing the OLWS or OLAI software, contact the 
Crestron Fusion Support Group at 1-888-273-7876, Option 1 or email FSG@crestron.com.  

Outlook Add-In Web Service (Server-Side) Installation 
To install the OLWS, complete the following steps: 

1. For a client installation, right-click the cmd.exe shortcut, and then click Run as 
Administrator. 

In the Administrator: Command Prompt window, enter msiexec /i [MSI PATH] into 
the command line prompt. [MSI PATH] is the path to the msi file.  

Verify that the command is similar to the following:  
C:\Temp>msiexec /i c:\temp\OutlookWebServiceSetup_10_x_x.msi 

2. From the Welcome window, click Next. The Select Installation Address window 
opens. 

3. Select Fusion Outlook Web Service from the Application Pool drop-down list. 

4. Click Next and then click Next again to open the Installing Crestron Fusion 
Outlook Web Service window. Please Wait should be displayed in the window. 

5. After the installation is complete, close the Setup panel. An IIS reset is not required. 

6. To verify the URI address of the OLAI, open a web browser on a client or a staging 
computer.  

7. Depending on your version of Crestron Fusion, enter the applicable command to 
install the OLAI into the command line prompt and then press Enter. 

•  For a default Creston Fusion 9.x installation, enter  
http://[server name]/roomviewse/outlookwebservice/addinservice.asmx. 

mailto:FSG@crestron.com
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•  For a default Crestron Fusion 10.x installation, enter  
http://[server name]/fusion/outlookwebservice/addinservice.asmx. 

Verify that the page loaded displays AddinService in the heading. 

AddinService Window 

 

After completing the OLWS installation, the OLAI needs to be installed. Depending 
on your version of Outlook, choose the applicable installation method: 

• Crestron Fusion Add-In for Outlook (UI Assisted 32-Bit) installation 

• Crestron Fusion Add-In for Outlook (Command Line 32-Bit) installation 

• Crestron Fusion Add-In for Outlook (UI Assisted 64-Bit) installation 

• Crestron Fusion Add-In for Outlook (Command Line 64-Bit) installation 

Instructions for each of these installation methods are described in the sections that 
follow. 

Crestron Fusion Add-In for Outlook (UI Assisted 32-Bit) Installation 
To install the OLAI, complete the following steps: 

1. Depending on your version of Outlook, use one of the following methods to verify 
that Outlook is 32-bit. 

•  For Outlook 2007, click Help > About. The bit count is displayed. 

•  For Outlook 2010 and 2013, click File > Help. The bit count is displayed 
under the About Microsoft Outlook section.  

2. To verify the URI address of the OLWS, open a web browser on a client or a 
staging computer.  

3. Depending on your version of Crestron Fusion, enter the applicable command into 
the browser and then press Enter. 

•  For a default Creston Fusion 9.x installation, enter  
http://[server name]/roomviewse/outlookwebservice/addinservice.asmx. 

•  For a default Crestron Fusion 10.x installation, enter  
http://[server name]/fusion/outlookwebservice/addinservice.asmx. 

Verify that the page loaded displays AddinService in the heading. 

AddinService Window 
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4. Right-click the RVOutlookAddinSetup_x_x_x_32bit.exe, and then click Run as 
Administrator to open the Welcome to the Crestron Fusion Add-In for Outlook 
Setup Wizard window. 

Welcome to the Crestron Fusion Add-in for Outlook Setup Wizard Window 

 

5. Click Next to open the Ready to Install window. 

Ready to Install Window 

 

6. Click Install to open the Installing window. 
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Installing Window 

 

After the setup process is complete, the Welcome to the Crestron Fusion  
Add-In for Outlook Setup Wizard window opens. 

Welcome to the Crestron Fusion Add-in for Outlook Setup Wizard Window 

 

7. Click Next to open the License Agreement window. 
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License Agreement Window 

 

8. Review the license agreement, and then click I Agree.  

9. Click Next to open the Outlook Web Service window. 

Outlook Web Service Window 

 

10. Enter the URL in the Web Service Folder field. Click Next to open the Select 
Installation Folder window. 



 

Installation Guide – DOC. 7726B Crestron Fusion Add-In for Outlook: Meeting Scheduling Software • 7 

Select Installation Folder Window 

 

11. To install the OLAI into a different folder, enter the desired location into the Folder 
field, or click Browse to choose a location. 

12. Click Disk Cost to open the Crestron Fusion Add-in for Outlook Disk Space 
window. Choose a drive to install the OLAI, view the disk space information, and 
then click OK. 

Crestron Fusion Add-In for Outlook Disk Space Window 

 

13. Click Next from the Select Installation Folder window to open the Confirm 
Installation window. 
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Confirm Installation Window 

 

14. Click Next to confirm the installation, and open the Installing Crestron Fusion  
Add-in for Outlook window. 

Installing Crestron Fusion Add-in for Outlook Window 

 

After the OLAI is installed, the Installation Complete window opens. 
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Installation Complete Window 

 

15. Click Close to open the Completing the Crestron Fusion Add-in for Outlook 
Setup Wizard window. 

Completing the Crestron Fusion Add-in for Outlook Setup Wizard Window 

 

16. Click Finish.  

17. To validate the installation, wait at least 5 minutes and then close and re-open 
Outlook. 
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18. Click Calendar, and then click New Meeting to open a meeting. 

Calendar and New Meeting 

 

 

19. Click Crestron RoomView™ to load the Fusion RV services. 

Crestron RoomView 

 

When the Fusion RV services are loaded, a region list is displayed in the Room 
Selection window. 

NOTE: The Fusion RV services may take some time to load. 

Room Selection Window Displaying a Region List 

 

Crestron Fusion Add-In for Outlook (Command Line 32-Bit) Installation 
To install the OLAI, complete the following steps: 

1. Depending on your version of Outlook, use one of the following methods to verify 
that Outlook is 32-bit. 

•  For Outlook 2007, click Help > About. The bit count is displayed. 

•  For Outlook 2010 and 2013, click File > Help. The bit count is displayed 
under the About Microsoft Outlook section.  

2. To verify the URI address of the OLWS, open a web browser on a client or staging 
computer. 
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3. Depending on the version of Crestron Fusion, enter the applicable command into
the browser, and then press Enter.

• For a default Creston Fusion 9.x installation, enter
http://[server name]/roomviewse/outlookwebservice/addinservice.asmx.

• For a default Crestron Fusion 10.x installation, enter
http://[server name]/fusion/outlookwebservice/addinservice.asmx.

Verify that the page loaded displays AddinService in the heading. 

AddinService Window 

4. Depending on the installation type, use one of the following methods to run the
command line prompt as an administrator.

• For a client installation, right-click the cmd.exe shortcut, and then click
Run as Administrator.

• For an automated distribution, locate the prompt, and enter the command
in the distribution software. Verify that the account is run as an
administrator.

5. Enter [EXE path] /[URI Address] /verysilent into the command line prompt to install
the OLAI.

• [EXE path] is RVOutlookAddinSetup_x_x_x_32bit.exe

• [URI Address] is url=http://[ServerName]/fusion/outlookwebservice

Refer to the table below for information on switches. 

Switch Type Description 
/bsn This switch activates the BookSingle features and is either true or false. 

To enable the BookSingle functionality, add /BSN=true to the command 
above, for example RVOutlookAddinSetup.exe /bsn=true. 

/silent This switch runs setup automatically with the UI displayed. Input is 
inhibited. 

/url This switch sets the path to the Outlook web service. 

/verysilent This switch inhibits the UI and runs setup automatically. 

8. Depending on the installation type, use one of the following methods to run the
installation command.

• For a client installation, press Enter at the command prompt.

• For an automated installation, consult the manufacturer’s instructions on
how to run the command.

6. To validate the installation, wait at least 5 minutes and then close and re-open
Outlook.

7. Click Calendar, and then click New Meeting to open a meeting.
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Calendar and New Meeting 

 

 

8. Click Crestron RoomView to load the Fusion RV services. 

Crestron RoomView 

 

When the Fusion RV services are loaded, a region list is displayed in the Room 
Selection window. 

NOTE: The Fusion RV services may take some time to load. 

Room Selection Window Displaying a Region List 

 

Crestron Fusion Add-In for Outlook (UI Assisted 64-Bit) Installation 
To install the OLAI, complete the following steps: 

1. Depending on your version of Outlook, use of the following methods to verify that 
Outlook is 64-bit. 

•  For Outlook 2007, click Help > About. The bit count is displayed. 

•  For Outlook 2010 and 2013, click File > Help. The bit count is displayed 
under the About Microsoft Outlook section.  

2. To verify the URI address of the OLWS, open a web browser on a client or a 
staging computer. 

3. Depending on the version of Crestron Fusion, enter one of the following addresses 
into the browser, and then press Enter. 
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•  For a default Creston Fusion 9.x installation, enter  
http://[server name]/roomviewse/outlookwebservice/addinservice.asmx. 

•  For a default Crestron Fusion 10.x installation, enter  
http://[server name]/fusion/outlookwebservice/addinservice.asmx. 

Verify that the page loaded displays AddinService in the heading. 

AddinService Window 

 

4. Right-click the RVOutlookAddinSetup_x_x_x_64bit.exe, and then click Run as 
Administrator to open the Welcome to the Crestron Fusion Add-in for Outlook 
Setup Wizard window. 

Welcome to the Crestron Fusion Add-in for Outlook Setup Wizard Window 

 

5. Click Next to open the Ready to Install window.  
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Ready to Install Window 

 

6. Click Install to open the Installing window. 

Installing Window 

 

After the setup process is complete, the Welcome to the Crestron Fusion  
Add-in for Outlook Setup Wizard window opens. 
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Welcome to the Crestron Fusion Add-in for Outlook Setup Wizard Window 

 

7. Click Next to open the License Agreement window. 

License Agreement Window 

 

8. Review the license agreement, and then click I Agree. Click Next to open the 
Outlook Web Service window. 
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Outlook Web Service Window 

 

9. Enter the URL in the Web Service Folder field. Click Next to open the Select 
Installation Folder window. 

Select Installation Folder Window 

 

10. To install the OLAI into a different folder, enter the desired location into the Folder 
field or click Browse to choose a location. 

11. Click Disk Cost to open the Crestron Fusion Add-in for Outlook Disk Space 
window.  
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Crestron Fusion Add-in for Outlook Disk Space Window 

 

12. Choose a drive to install the OLAI and view the disk space information. Click OK. 

13. Click Next from the Select Installation Folder window to open the Confirm 
Installation window. 

Confirm Installation Window 

 

14. Click Next to confirm the installation and open the Installing Crestron Fusion  
Add-in for Outlook window. 



 

18 • Crestron Fusion Add-In for Outlook: Meeting Scheduling Software  Installation Guide – DOC. 7726B 

Installing Crestron Fusion Add-in for Outlook Window 

 

After the OLAI is installed, the Installation Complete window opens. 

Installation Complete Window 

 

15. Click Close to open the Completing the Crestron Fusion Add-in for Outlook 
Setup Wizard window. 
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Completing the Crestron Fusion Add-In for Outlook Setup Wizard Window 

 

16. Click Finish.  

17. To validate the installation, wait at least 5 minutes and then close and re-open 
Outlook. 

18. Click Calendar and then click New Meeting to open a meeting. 

Calendar and New Meeting 

 

 

19. Click Crestron RoomView to load the Fusion RV services. 

Crestron RoomView 

 

When the Fusion RV services are loaded, a region list is displayed in the Room 
Selection window. 

NOTE: The Fusion RV services may take some time to load. 
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Room Selection Window Displaying a Region List 

 

Crestron Fusion Add-In for Outlook (Command Line 64-Bit) Installation 
To install the OLAI, complete the following steps: 

1. Depending on your version of Outlook, use one of the following methods to verify 
that Outlook is 64-bit. 

•  For Outlook 2007, click Help > About. The bit count is displayed. 

•  For Outlook 2010 and 2013, click File > Help. The bit count is displayed 
under the About Microsoft Outlook section.  

2. To verify the URI address of the OLWS, open a web browser on a client or a 
staging computer.  

3. Depending on the version of Crestron Fusion, enter one of the following addresses 
into the browser, and then press Enter. 

•  For a default Creston Fusion 9.x installation, enter  
http://[server name]/roomviewse/outlookwebservice/addinservice.asmx. 

•  For a default Fusion 10.x installation, enter  
http://[server name]/fusion/outlookwebservice/addinservice.asmx. 

Verify that the page loaded displays AddinService in the heading. 

AddinService Window 

 

4. Depending on the installation type, use one of the following methods to run the 
command line prompt as an administrator. 

•  For a client installation, right-click the cmd.exe shortcut, and then click 
Run as Administrator. 

•  For an automated distribution, locate the prompt, and enter the command 
in the distribution software. Verify that the account is run as an 
administrator. 
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5. Enter [EXE path] /[URI Address] /verysilent into the command line prompt to install
the OLAI.

• [EXE path] is RVOutlookAddinSetup_x_x_x_64bit.exe

• [URI Address] is url=http://ServerName/Fusion/outlookwebservice

Refer to the table below for information on switch types. 

Switch Type Description 

/bsn This switch activates the BookSingle features and is either true or false. 
To enable the BookSingle functionality, add /BSN=true to the command 
above, for example RVOutlookAddinSetup.exe /bsn=true. 

/silent This switch runs setup automatically with the UI displayed. Input is 
inhibited. 

/url This switch sets the path to the Outlook web service. 

/verysilent This switch inhibits the UI and runs setup automatically. 

6. Depending on the installation type, use one of the following methods to run the
installation command.

• For a client installation, press Enter at the command prompt.

• For an automated installation, consult the manufacturer’s instructions on
how to run the command. Wait at least 5 minutes before validating the
installation.

7. To validate the installation, wait at least 5 minutes and then close and re-open
Outlook.

8. Click Calendar, and then click New Meeting to open a meeting.

Calendar and New Meeting 

9. Click Crestron RoomView to load the Fusion RV services.

Crestron RoomView 

When the Fusion RV services are loaded, a region list is displayed in the Room 
Selection window. 



 

22 • Crestron Fusion Add-In for Outlook: Meeting Scheduling Software  Installation Guide – DOC. 7726B 

NOTE: The Fusion RV services may take some time to load. 

Room Selection Window Displaying a Region List 
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